# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(fiktiv)|[^0-9]/$1/g;t' <<< "123456788daswqrt fiktiv"