using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(fiktiv)|[^0-9]";
string substitution = @"$1";
string input = @"123456788daswqrt fiktiv";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}