#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(fiktiv)|[^0-9]"
Local $sString = "123456788daswqrt fiktiv"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)