use strict;
my $str = '123456788daswqrt fiktiv';
my $regex = qr/(fiktiv)|[^0-9]/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";