import Foundation
let pattern = #"(fiktiv)|[^0-9]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"123456788daswqrt fiktiv"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)