const regex = /(fiktiv)|[^0-9]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(fiktiv)|[^0-9]', 'g')
const str = `123456788daswqrt fiktiv`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);