using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-][\w]{8}\.";
string input = @"P38_3062008153730_All C a circ038 - Certificato Quietanza Canone-k8vW6APY.pdf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}