import re
regex = re.compile(r"[-][\w]{8}\.")
test_str = "P38_3062008153730_All C a circ038 - Certificato Quietanza Canone-k8vW6APY.pdf"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")