$re = '/[-][\w]{8}\./';
$str = 'P38_3062008153730_All C a circ038 - Certificato Quietanza Canone-k8vW6APY.pdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);