const regex = new RegExp('[-][\\w]{8}\\.', '')
const str = `P38_3062008153730_All C a circ038 - Certificato Quietanza Canone-k8vW6APY.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}