re = /[-][\w]{8}\./
str = 'P38_3062008153730_All C a circ038 - Certificato Quietanza Canone-k8vW6APY.pdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end