package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-][\w]{8}\.`)
var str = `P38_3062008153730_All C a circ038 - Certificato Quietanza Canone-k8vW6APY.pdf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}