import Foundation
let pattern = #"[-][\w]{8}\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"P38_3062008153730_All C a circ038 - Certificato Quietanza Canone-k8vW6APY.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}