using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=src\s*\=\s*\"")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\&rel\\=[01]\\""))|(?<=src\\s*\\=\\s*\\"")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\""))|(?<Url>^http://www\\.youtube\\.com/(v|embed)/.+?$)";
string input = @"Lorem ipsum dolor anka. sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco <span class=""></span > Diabetes laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in Banjo reprehenderit in Anka voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum e. span";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}