import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=src\\s*\\=\\s*\\\")(?<Url>http://www\\\\.youtube\\\\.com/(v|embed)/.+?(?=\\\\&rel\\\\=[01]\\\\\"))|(?<=src\\\\s*\\\\=\\\\s*\\\\\")(?<Url>http://www\\\\.youtube\\\\.com/(v|embed)/.+?(?=\\\\\"))|(?<Url>^http://www\\\\.youtube\\\\.com/(v|embed)/.+?$)";
final String string = "Lorem ipsum dolor anka. sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco <span class=\"\"></span > Diabetes laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in Banjo reprehenderit in Anka voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum e. span";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}