use strict;
my $str = 'Lorem ipsum dolor anka. sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco <span class=""></span > Diabetes laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in Banjo reprehenderit in Anka voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum e. span';
my $regex = qr/(?<=src\s*\=\s*\")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\&rel\\=[01]\\"))|(?<=src\\s*\\=\\s*\\")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\"))|(?<Url>^http://www\\.youtube\\.com/(v|embed)/.+?$)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}