import Foundation
let pattern = #"(?<=src\s*\=\s*\")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\&rel\\=[01]\\"))|(?<=src\\s*\\=\\s*\\")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\"))|(?<Url>^http://www\\.youtube\\.com/(v|embed)/.+?$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Lorem ipsum dolor anka. sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco <span class=""></span > Diabetes laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in Banjo reprehenderit in Anka voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum e. span"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)