# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=src\s*\=\s*\")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\&rel\\=[01]\\\"))|(?<=src\\s*\\=\\s*\\\")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\\"))|(?<Url>^http://www\\.youtube\\.com/(v|embed)/.+?$)"
test_str = "Lorem ipsum dolor anka. sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco <span class=\"\"></span > Diabetes laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in Banjo reprehenderit in Anka voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum e. span"
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.