$re = '/(?<=src\s*\=\s*\")(?<Url>http://www\\\\.youtube\\\\.com/(v|embed)/.+?(?=\\\\&rel\\\\=[01]\\\\"))|(?<=src\\\\s*\\\\=\\\\s*\\\\")(?<Url>http://www\\\\.youtube\\\\.com/(v|embed)/.+?(?=\\\\"))|(?<Url>^http://www\\\\.youtube\\\\.com/(v|embed)/.+?$)/i';
$str = 'Lorem ipsum dolor anka. sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco <span class=""></span > Diabetes laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in Banjo reprehenderit in Anka voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum e. span';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);