# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^A-Z\S\r\na-z.0-9:;$-]+/ /g;t' <<< "This is a test.
This is a newline.
this is another newline. This is a, comma"