using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^A-Z\S\r\na-z.0-9:;$-]+";
string substitution = @" ";
string input = @"This is a test.
This is a newline.
this is another newline. This is a, comma";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}