#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^A-Z\S\r\na-z.0-9:;$-]+"
Local $sString = "This is a test. " & @CRLF & _
" This is a newline. " & @CRLF & _
" this is another newline. This is a, comma"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)