use strict;
my $str = 'This is a test.
This is a newline.
this is another newline. This is a, comma';
my $regex = qr/[^A-Z\S\r\na-z.0-9:;$-]+/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";