re = /[^A-Z\S\r\na-z.0-9:;$-]+/
str = 'This is a test.
This is a newline.
this is another newline. This is a, comma'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result