import Foundation
let pattern = #"[^A-Z\S\r\na-z.0-9:;$-]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This is a test.
This is a newline.
this is another newline. This is a, comma
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)