package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^A-Z\S\r\na-z.0-9:;$-]+`)
var str = `This is a test.
This is a newline.
this is another newline. This is a, comma`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}