#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\B\$\w+"
Local $sString = "$folders[] = ['name' => $controller, 'icon' => 'folder-o'];" & @CRLF & _
"asd$controlle - не переменная" & @CRLF & _
"А это переменные: $a, $b,$cde,[$qwe-$lol]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")