package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B\$\w+`)
var str = `$folders[] = ['name' => $controller, 'icon' => 'folder-o'];
asd$controlle - не переменная
А это переменные: $a, $b,$cde,[$qwe-$lol]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}