import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B\\$\\w+";
final String string = "$folders[] = ['name' => $controller, 'icon' => 'folder-o'];\n"
+ "asd$controlle - не переменная\n"
+ "А это переменные: $a, $b,$cde,[$qwe-$lol]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}