using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B\$\w+";
string input = @"$folders[] = ['name' => $controller, 'icon' => 'folder-o'];
asd$controlle - не переменная
А это переменные: $a, $b,$cde,[$qwe-$lol]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}