$re = '/\B\$\w+/';
$str = '$folders[] = [\'name\' => $controller, \'icon\' => \'folder-o\'];
asd$controlle - не переменная
А это переменные: $a, $b,$cde,[$qwe-$lol]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);