re = /\B\$\w+/
str = '$folders[] = [\'name\' => $controller, \'icon\' => \'folder-o\'];
asd$controlle - не переменная
А это переменные: $a, $b,$cde,[$qwe-$lol]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end