// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\B\$\w+").unwrap();
let string = "$folders[] = ['name' => $controller, 'icon' => 'folder-o'];
asd$controlle - не переменная
А это переменные: $a, $b,$cde,[$qwe-$lol]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}