using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\w\]\)])(=)(?=\w)";
string substitution = @" $1 ";
string input = @"asdas=3243
asdasd[123]=addddddsda";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}