const regex = /(?<=[\w\]\)])(=)(?=\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\w\\]\\)])(=)(?=\\w)', 'g')
const str = `asdas=3243
asdasd[123]=addddddsda`;
const subst = ` $1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);