$re = '/(?<=[\w\]\)])(=)(?=\w)/';
$str = 'asdas=3243
asdasd[123]=addddddsda';
$subst = " $1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;