re = /(?<=[\w\]\)])(=)(?=\w)/
str = 'asdas=3243
asdasd[123]=addddddsda'
subst = ' $1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result