import re
regex = re.compile(r"(?<=[\w\]\)])(=)(?=\w)")
test_str = ("asdas=3243\n"
"asdasd[123]=addddddsda")
subst = " $1 "
result = regex.sub(subst, test_str)
if result:
print(result)