# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/rgba(?=(.*)<\\/tspan>)/rgb/g;t' <<< "<text>
<tspan stroke='' opacity='' fill='rgba(0,0,0,0)'>abc</tspan>
<tspan fill='rgba(0,0,0,0)'><h1>anything</h1></tspan>
</text>
<rect fill='rgba(0,0,0,0)'></rect>"