using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rgba(?=(.*)<\/tspan>)";
string substitution = @"rgb";
string input = @"<text>
<tspan stroke='' opacity='' fill='rgba(0,0,0,0)'>abc</tspan>
<tspan fill='rgba(0,0,0,0)'><h1>anything</h1></tspan>
</text>
<rect fill='rgba(0,0,0,0)'></rect>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}