re = /rgba(?=(.*)<\/tspan>)/
str = '<text>
<tspan stroke=\'\' opacity=\'\' fill=\'rgba(0,0,0,0)\'>abc</tspan>
<tspan fill=\'rgba(0,0,0,0)\'><h1>anything</h1></tspan>
</text>
<rect fill=\'rgba(0,0,0,0)\'></rect>'
subst = 'rgb'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result