import Foundation
let pattern = #"rgba(?=(.*)<\/tspan>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<text>
<tspan stroke='' opacity='' fill='rgba(0,0,0,0)'>abc</tspan>
<tspan fill='rgba(0,0,0,0)'><h1>anything</h1></tspan>
</text>
<rect fill='rgba(0,0,0,0)'></rect>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"rgb"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)