# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"rgba(?=(.*)<\/tspan>)"
test_str = ("<text>\n"
" <tspan stroke='' opacity='' fill='rgba(0,0,0,0)'>abc</tspan>\n"
" <tspan fill='rgba(0,0,0,0)'><h1>anything</h1></tspan>\n"
"</text>\n"
"<rect fill='rgba(0,0,0,0)'></rect>")
subst = "rgb"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.