use strict;
my $str = '<text>
<tspan stroke=\'\' opacity=\'\' fill=\'rgba(0,0,0,0)\'>abc</tspan>
<tspan fill=\'rgba(0,0,0,0)\'><h1>anything</h1></tspan>
</text>
<rect fill=\'rgba(0,0,0,0)\'></rect>';
my $regex = qr/rgba(?=(.*)<\/tspan>)/p;
my $subst = 'rgb';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";