# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?s(\d{2})((?:e\d{2})+)\..*/Season: $1 - Episodes: $2/;t' <<< "showname.s01e01e02e03.extension"