re = /^.*?s(\d{2})((?:e\d{2})+)\..*/
str = 'showname.s01e01e02e03.extension'
subst = 'Season: $1 - Episodes: $2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result