import re
regex = re.compile(r"^.*?s(\d{2})((?:e\d{2})+)\..*")
test_str = "showname.s01e01e02e03.extension"
subst = "Season: $1 - Episodes: $2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)