using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?s(\d{2})((?:e\d{2})+)\..*";
string substitution = @"Season: $1 - Episodes: $2";
string input = @"showname.s01e01e02e03.extension";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}