const regex = /^.*?s(\d{2})((?:e\d{2})+)\..*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?s(\\d{2})((?:e\\d{2})+)\\..*', '')
const str = `showname.s01e01e02e03.extension`;
const subst = `Season: $1 - Episodes: $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);