// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^.*?s(\d{2})((?:e\d{2})+)\..*").unwrap();
let string = "showname.s01e01e02e03.extension";
let substitution = "Season: $1 - Episodes: $2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}